GetExportLayerInfo Method


Gets a copy of the layer info associated to the input pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public ExportLayerInfo GetExportLayerInfo(
	ExportLayerKey exportLayerKey
)
Visual Basic
Public Function GetExportLayerInfo ( _
	exportLayerKey As ExportLayerKey _
) As ExportLayerInfo
Visual C++
public:
ExportLayerInfo^ GetExportLayerInfo(
	ExportLayerKey^ exportLayerKey
)

Parameters

exportLayerKey
Type: Autodesk.Revit.DBExportLayerKey
The export layer Key.

Return Value

Return the layerInfo for this key.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException An entry with the given key is not present in the table.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also