GetSubelement Method (String)


Gets the subelement referenced by a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public Subelement GetSubelement(
	string uniqueId
)
Visual Basic
Public Function GetSubelement ( _
	uniqueId As String _
) As Subelement
Visual C++
public:
Subelement^ GetSubelement(
	String^ uniqueId
)

Parameters

uniqueId
Type: SystemString
The unique id that identifies element or subelement.
  • UniqueId
  • Return Value

    The subelement referenced by the input argument.

    Remarks

    a null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid element or subelement.

    Exceptions

    ExceptionCondition
    Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

    See Also