GetSubelement Method (String)


Document Get Subelement(String) Method

Gets the subelement referenced by a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Subelement GetSubelement(
	string uniqueId
)

Parameters

uniqueId String
The unique id that identifies element or subelement.
  • UniqueId
  • Return Value

    Subelement
    The subelement referenced by the input argument.
    Exceptions
    Exception Condition
    ArgumentNullException A non-optional argument was null
    Remarks
    will be returned if the input id string doesn't reference to a valid element or subelement.
    See Also