Identify whether the points can construct a valid region for a topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- points
- Type: System.Collections.GenericIListXYZ
The points set to be checked.
Return Value
True if the size of points is not less than 3 and the points are not collinear after projecting to XY plane, that is, ignoring the elevation.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | There are no points in the input points set. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |