Topography |
Identify whether the points can construct a valid region for a topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
Return Value
BooleanTrue if the size of points is not less than 3 and the points are not collinear after projecting to XY plane, that is, ignoring the elevation.

Exception | Condition |
---|---|
ArgumentException | There are no points in the input points set. |
ArgumentNullException | A non-optional argument was null |