AttachChord Method


Attach a truss's specific chord to a specified element, the element should be a roof or floor.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void AttachChord(
	Element attachToElement,
	TrussChordLocation location,
	bool forceRemoveSketch
)
Visual Basic
Public Sub AttachChord ( _
	attachToElement As Element, _
	location As TrussChordLocation, _
	forceRemoveSketch As Boolean _
)
Visual C++
public:
void AttachChord(
	Element^ attachToElement, 
	TrussChordLocation location, 
	bool forceRemoveSketch
)

Parameters

attachToElement
Type: Autodesk.Revit.DBElement
The element to which the truss's chord will attach. The element should be a roof or floor.
location
Type: Autodesk.Revit.DB.StructureTrussChordLocation
The chord need to be attached.
forceRemoveSketch
Type: SystemBoolean
Whether to detach the original sketch if there is one.

See Also