Truss Attach |
Attach a truss's specific chord to a specified element, the element should be a roof or floor.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void AttachChord(
Element attachToElement,
TrussChordLocation location,
bool forceRemoveSketch
)
Parameters
- attachToElement Element
- The element to which the truss's chord will attach. The element should be a roof or floor.
- location TrussChordLocation
- The chord need to be attached.
- forceRemoveSketch Boolean
- Whether to detach the original sketch if there is one.