SetRenderingAsset Method


Sets the rendering asset for the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void SetRenderingAsset(
	Asset asset
)
Visual Basic
Public Sub SetRenderingAsset ( _
	asset As Asset _
)
Visual C++
public:
void SetRenderingAsset(
	Asset^ asset
)

Parameters

asset
Type: Autodesk.Revit.DB.VisualAsset
The new rendering asset. It should be an appearance asset.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The asset is not an appearance asset.

See Also