SetRenderingAsset Method


Appearance Asset Element Set Rendering Asset Method

Sets the rendering asset for the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetRenderingAsset(
	Asset asset
)

Parameters

asset Asset
The new rendering asset. It should be an appearance asset.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The asset is not an appearance asset.
See Also