CreateDuctConnector Method (Document, DuctSystemType, ConnectorProfileType, Reference)


Create a new duct ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static ConnectorElement CreateDuctConnector(
	Document document,
	DuctSystemType ductSystemType,
	ConnectorProfileType profileShape,
	Reference planarFace
)
Visual Basic
Public Shared Function CreateDuctConnector ( _
	document As Document, _
	ductSystemType As DuctSystemType, _
	profileShape As ConnectorProfileType, _
	planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateDuctConnector(
	Document^ document, 
	DuctSystemType ductSystemType, 
	ConnectorProfileType profileShape, 
	Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to add the connector to.
ductSystemType
Type: Autodesk.Revit.DB.MechanicalDuctSystemType
The DuctSystemType of the connector.
profileShape
Type: Autodesk.Revit.DBConnectorProfileType
The profile shape of the duct.
planarFace
Type: Autodesk.Revit.DBReference
The planar face to place the connector on.

Return Value

The duct ConnectorElement.

Remarks

Regenerates the document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException Connector creation is not allowed in this family.

See Also