CreateDuctConnector Method (Document, DuctSystemType, ConnectorProfileType, Reference)


Connector Element Create Duct Connector(Document, Duct System Type, Connector Profile Type, Reference) Method

Create a new duct ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ConnectorElement CreateDuctConnector(
	Document document,
	DuctSystemType ductSystemType,
	ConnectorProfileType profileShape,
	Reference planarFace
)

Parameters

document Document
The document to add the connector to.
ductSystemType DuctSystemType
The DuctSystemType of the connector.
profileShape ConnectorProfileType
The profile shape of the duct.
planarFace Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The duct ConnectorElement.
Exceptions
Exception Condition
ArgumentException The reference is not a planar face. -or- document is not a family document.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also