ModifySubElement Method (SlabShapeCrease, Double)


Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ModifySubElement(
	SlabShapeCrease crease,
	double offset
)
Visual Basic
Public Sub ModifySubElement ( _
	crease As SlabShapeCrease, _
	offset As Double _
)
Visual C++
public:
void ModifySubElement(
	SlabShapeCrease^ crease, 
	double offset
)

Parameters

crease
Type: Autodesk.Revit.DBSlabShapeCrease
The crease.
offset
Type: SystemDouble
The new value of the crease offset, which is the average of offsets of its ends.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the crease is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the crease is invalid.

See Also