IsValidCurve Method


Verifies if the curve is valid for an Analytical Member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public static bool IsValidCurve(
	Curve curve
)
Visual Basic
Public Shared Function IsValidCurve ( _
	curve As Curve _
) As Boolean
Visual C++
public:
static bool IsValidCurve(
	Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DBCurve
The curve to be verified.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also