RoutingConditions Constructor


Constructs a new instance of a RoutingConditions object with an indicated error level for conditions that do not meet any routing preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public RoutingConditions(
	RoutingPreferenceErrorLevel errorLevel
)
Visual Basic
Public Sub New ( _
	errorLevel As RoutingPreferenceErrorLevel _
)
Visual C++
public:
RoutingConditions(
	RoutingPreferenceErrorLevel errorLevel
)

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also