Creates a new SolidOptions class with material and graphics style settings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- materialId
- Type: Autodesk.Revit.DBElementId
The material id for the Solid.
- graphicsStyleId
- Type: Autodesk.Revit.DBElementId
The graphics style id for the Solid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |