SolidOptions Constructor


Solid Options Constructor

Creates a new SolidOptions class with material and graphics style settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SolidOptions(
	ElementId materialId,
	ElementId graphicsStyleId
)

Parameters

materialId ElementId
The material id for the Solid.
graphicsStyleId ElementId
The graphics style id for the Solid.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also