Create Method (Document, IList(ElementId), ElementId)


Creates a new instance of a Structural Connection Handler, which defines the connection between given elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static StructuralConnectionHandler Create(
	Document document,
	IList<ElementId> idsToConnect,
	ElementId typeId
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	idsToConnect As IList(Of ElementId), _
	typeId As ElementId _
) As StructuralConnectionHandler
Visual C++
public:
static StructuralConnectionHandler^ Create(
	Document^ document, 
	IList<ElementId^>^ idsToConnect, 
	ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The Revit document.
idsToConnect
Type: System.Collections.GenericIListElementId
List of element ids of connected elements.
typeId
Type: Autodesk.Revit.DBElementId
The type of Structural Connection Handler.

Return Value

The newly created connection.

Remarks

Elements should be of the following structural categories: framings (OST_StructuralFraming), columns (OST_StructuralColumns), walls (OST_Walls), floors (OST_Floors) or foundations (OST_StructuralFoundations). The first of given elements is set as primary one.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException It verifies that we have at least one element id in the list. -or- The type typeId is not a valid StructuralConnectionHandlerType. -or- Missing detailed structural connection service implementation.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also