GetFaceOffset Method


Get face offset of the given part face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public double GetFaceOffset(
	Face face
)
Visual Basic
Public Function GetFaceOffset ( _
	face As Face _
) As Double
Visual C++
public:
double GetFaceOffset(
	Face^ face
)

Parameters

face
Type: Autodesk.Revit.DBFace
The face whose offset is required.

Return Value

Returns the value of the offset.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException face does not belong to the part.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also