GetWallTrimmedCurve Method


Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static Curve GetWallTrimmedCurve(
	Wall pVWall
)
Visual Basic
Public Shared Function GetWallTrimmedCurve ( _
	pVWall As Wall _
) As Curve
Visual C++
public:
static Curve^ GetWallTrimmedCurve(
	Wall^ pVWall
)

Parameters

pVWall
Type: Autodesk.Revit.DBWall
The wall.

Return Value

The trimmed or extended curve.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also