InsertImage Method


Inserts a image in the given cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void InsertImage(
	int nRow,
	int nColumn,
	ElementId imageSymbolId
)
Visual Basic
Public Sub InsertImage ( _
	nRow As Integer, _
	nColumn As Integer, _
	imageSymbolId As ElementId _
)
Visual C++
public:
void InsertImage(
	int nRow, 
	int nColumn, 
	ElementId^ imageSymbolId
)

Parameters

nRow
Type: SystemInt32
The given row index.
nColumn
Type: SystemInt32
The given column index.
imageSymbolId
Type: Autodesk.Revit.DBElementId
The element id of the image symbol.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given row number nRow is invalid. -or- The given column number nColumn is invalid. -or- The image symbol id doesn't represent a valid image symbol element.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also