Sets the options to use for this DirectShape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- options
- Type: Autodesk.Revit.DBDirectShapeOptions
Options to use for this DirectShape.
Remarks
The new options take effect immediately. If this DirectShape relies on a DirectShapeType for references, the options stored in DirectShapeType take precedence. Note that changing options affects how the object interacts with Revit. E.g., switching references off will disable existing constraints applied to that object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The DirectShapeOptions provided are not valid for this DirectShape. -or- The DirectShapeOptions provided are not valid for this transient DirectShape. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |