SetOptions Method


Direct Shape Set Options Method

Sets the options to use for this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetOptions(
	DirectShapeOptions options
)

Parameters

options DirectShapeOptions
Options to use for this DirectShape.
Exceptions
Exception Condition
ArgumentException The DirectShapeOptions provided are not valid for this DirectShape. -or- The DirectShapeOptions provided are not valid for this transient DirectShape.
ArgumentNullException A non-optional argument was null
Remarks
The new options take effect immediately. If this DirectShape relies on a DirectShapeType for references, the options stored in DirectShapeType take precedence. Note that changing options affects how the object interacts with Revit. E.g., switching references off will disable existing constraints applied to that object.
See Also