ComputeSurfaceArea Method


Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double ComputeSurfaceArea()
Visual Basic
Public Function ComputeSurfaceArea As Double
Visual C++
public:
double ComputeSurfaceArea()

Return Value

A double, representing the surface area.

See Also