HasTangentJoin Method


Tests whether this curve element and the input curve element have common tangent join at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public bool HasTangentJoin(
	int end,
	ElementId other
)
Visual Basic
Public Function HasTangentJoin ( _
	end As Integer, _
	other As ElementId _
) As Boolean
Visual C++
public:
bool HasTangentJoin(
	int end, 
	ElementId^ other
)

Parameters

end
Type: SystemInt32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
other
Type: Autodesk.Revit.DBElementId
ElementId of another Curve Element from the same document.

Return Value

Returns True if the two curve elements have a tangent join at the given end-point.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also