Autodesk.Revit.DB.ExternalService Namespace


 

Classes

  ClassDescription
Public classExternalService
This base class represents an external service inside Revit application.
Public classExternalServiceId
Unique identifier of an external service.
Public classExternalServiceOptions
Various options affecting the behavior of an External Service
Public classExternalServiceRegistry
This class gives access to external services. Use it to register external services with Revit and execute them. Only the application that registers a service is allowed to execute it.
Public classExternalServices
Provides a container of all Revit built-in ExternalServiceId instances.
Public classExternalServicesBuiltInExternalServices
A collection of ids for external services that are managed and used by Revit directly.
Public classMultiServerService
This class represents a multi-server service inside Revit application. It is created when an instance of IMultiServerService is registered with Revit.
Public classSingleServerService
This class represents a single-server service inside Revit application. It is created when an instance of ISingleServerService is registered with Revit.

Interfaces

  InterfaceDescription
Public interfaceIExternalData
The base interface for data classes used when executing servers of external services.
Public interfaceIExternalServer
The base interface for all external servers.
Public interfaceIExternalService
The base interface class for all external services.
Public interfaceIMultiServerService
The base interface class for all multi-server services.
Public interfaceISingleServerService
The base interface class for all single-server services.

Enumerations

  EnumerationDescription
Public enumerationDisparityResponse
An enumerated value to return from OnServerDiparity indicating what the service wants Revit to do as the post-action of the call.
Public enumerationExecutionPolicy
Controls how servers of multi-server external services are executed.
Public enumerationExternalServiceResult
An enumerated value representing a result from executing an external service.
Public enumerationServerChangeCause
Indicates the cause for the active server to be changed