GetLocalFileName Method


Get the local file name, including the path, corresponding to a linked IFC file. This will create a local copy of the IFC file if necessary.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static string GetLocalFileName(
	Document aDoc,
	string fileName
)
Visual Basic
Public Shared Function GetLocalFileName ( _
	aDoc As Document, _
	fileName As String _
) As String
Visual C++
public:
static String^ GetLocalFileName(
	Document^ aDoc, 
	String^ fileName
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document that will contain the IFC link.
fileName
Type: SystemString
The original file name and path.

Return Value

The local file name and path corresponding to the input file name.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Can't process file name.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also