GetLocalFileName Method


Importer IFCUtils Get Local File Name Method

Get the local file name, including the path, corresponding to a linked IFC file. This will create a local copy of the IFC file if necessary.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string GetLocalFileName(
	Document aDoc,
	string fileName
)

Parameters

aDoc Document
The document that will contain the IFC link.
fileName String
The original file name and path.

Return Value

String
The local file name and path corresponding to the input file name.
Exceptions
Exception Condition
ArgumentException Can't process file name.
ArgumentNullException A non-optional argument was null
See Also