Checks whether a field can be used for sorting/grouping.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldId
- Type: Autodesk.Revit.DBScheduleFieldId
The ID of the field to check.
Return Value
True if the field can be used for sorting/grouping, false otherwise.Remarks
Schedules cannot be sorted/grouped by the Count field, Percentage fields, or Formula fields that depend on Percentage fields because those types of fields don't have meaningful values until after sorting and grouping takes place.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |