Schedule |
Checks whether a field can be used for sorting/grouping.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- fieldId ScheduleFieldId
- The ID of the field to check.
Return Value
BooleanTrue if the field can be used for sorting/grouping, false otherwise.

Exception | Condition |
---|---|
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
ArgumentNullException | A non-optional argument was null |

Schedules cannot be sorted/grouped by the Count field, Percentage fields, or Formula fields that depend on Percentage fields because those types of fields don't have meaningful values until after sorting and grouping takes place.