GetDoorWindowOpeningHandle Method


Get the handle to the opening associated with a hosted (door/window) element from the internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public IFCAnyHandle GetDoorWindowOpeningHandle(
	ElementId familyInstanceId
)
Visual Basic
Public Function GetDoorWindowOpeningHandle ( _
	familyInstanceId As ElementId _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetDoorWindowOpeningHandle(
	ElementId^ familyInstanceId
)

Parameters

familyInstanceId
Type: Autodesk.Revit.DBElementId
The id of the door or window.

Return Value

The opening handle.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also