Creates a new ViewPlan.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to which the ViewPlan will be added.
- viewFamilyTypeId
- Type: Autodesk.Revit.DBElementId
The id of the ViewFamilyType which will be used by the new ViewPlan. The type needs to be a FloorPlan, CeilingPlan, AreaPlan, or StructuralPlan ViewType.
- levelId
- Type: Autodesk.Revit.DBElementId
The id of the Level to associate with the new plan view.
Return Value
The new ViewPlan.Examples

// Create a Level and a Floor Plan based on it
double elevation = 10.0;
Level level1 = Level.Create(document, elevation);
ViewPlan floorView = ViewPlan.Create(document, floorPlanId, level1.Id);
// Create another Level and a Ceiling Plan based on it
elevation += 10.0;
Level level2 = Level.Create(document, elevation);
ViewPlan ceilingView = ViewPlan.Create(document, ceilingPlanId, level2.Id);

' Create a Level and a Floor Plan based on it
Dim elevation As Double = 10.0
Dim level1 As Level = Level.Create(document, elevation)
Dim floorView As ViewPlan = ViewPlan.Create(document, floorPlanId, level1.Id)
' Create another Level and a Ceiling Plan based on it
elevation += 10.0
Dim level2 As Level = Level.Create(document, elevation)
Dim ceilingView As ViewPlan = ViewPlan.Create(document, ceilingPlanId, level2.Id)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This view family type is not a plan view type. -or- The ElementId levelId does not correspond to a Level. -or- StructuralPlans can only be created when the structural discipline is enabled whereas FloorPlans and CeilingPlans can only be created when architecture or MEP disciplines are enabled. -or- Plan view creation is not allowed in this family. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |