View |
Creates a new ViewPlan.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public static ViewPlan Create(
Document document,
ElementId viewFamilyTypeId,
ElementId levelId
)
Parameters
- document Document
- The document to which the ViewPlan will be added.
- viewFamilyTypeId ElementId
- The id of the ViewFamilyType which will be used by the new ViewPlan. The type needs to be a FloorPlan, CeilingPlan, AreaPlan, or StructuralPlan ViewType.
- levelId ElementId
- The id of the Level to associate with the new plan view.
Return Value
ViewPlanThe new ViewPlan.

Exception | Condition |
---|---|
ArgumentException | This view family type is not a plan view type. -or- The ElementId levelId does not correspond to a Level. -or- StructuralPlans can only be created when the structural discipline is enabled whereas FloorPlans and CeilingPlans can only be created when architecture or MEP disciplines are enabled. -or- Plan view creation is not allowed in this family. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |