ChangeHostReference Method (Reference)


Changes the connector host reference to a new planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public void ChangeHostReference(
	Reference planarFace
)
Visual Basic
Public Sub ChangeHostReference ( _
	planarFace As Reference _
)
Visual C++
public:
void ChangeHostReference(
	Reference^ planarFace
)

Parameters

planarFace
Type: Autodesk.Revit.DBReference
The planar face to place the connector on.

Remarks

The connector referenced by a planar face alone is placed at the plane origin, and may be moved later along the planar face.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The face is not a planar face.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also