ChangeHostReference Method (Reference)


Connector Element Change Host Reference(Reference) Method

Changes the connector host reference to a new planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ChangeHostReference(
	Reference planarFace
)

Parameters

planarFace Reference
The planar face to place the connector on.
Exceptions
Exception Condition
ArgumentException The face is not a planar face.
ArgumentNullException A non-optional argument was null
Remarks
The connector referenced by a planar face alone is placed at the plane origin, and may be moved later along the planar face.
See Also