AddIntersectionElement Method


Adds an intersection element to the divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public void AddIntersectionElement(
	ElementId newIntersectionElemId
)
Visual Basic
Public Sub AddIntersectionElement ( _
	newIntersectionElemId As ElementId _
)
Visual C++
public:
void AddIntersectionElement(
	ElementId^ newIntersectionElemId
)

Parameters

newIntersectionElemId
Type: Autodesk.Revit.DBElementId
The intersection element to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element newIntersectionElemId is not a level, grid, reference plane, or a curve element whose category is lines and reference lines.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also