SetSketchOnSurface Method


Sets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static void SetSketchOnSurface(
	CurveElement curveElem,
	bool sketchOnSurface
)
Visual Basic
Public Shared Sub SetSketchOnSurface ( _
	curveElem As CurveElement, _
	sketchOnSurface As Boolean _
)
Visual C++
public:
static void SetSketchOnSurface(
	CurveElement^ curveElem, 
	bool sketchOnSurface
)

Parameters

curveElem
Type: Autodesk.Revit.DBCurveElement
The CurveElement.
sketchOnSurface
Type: SystemBoolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input CurveElement is not a CurveByPoints.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also