Curve |
Sets the relationship between the CurveElement and face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- curveElem CurveElement
- The CurveElement.
- sketchOnSurface Boolean
- Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exception | Condition |
---|---|
ArgumentException | The input CurveElement is not a CurveByPoints. |
ArgumentNullException | A non-optional argument was null |