Returns AnalyticalNodeData associated with this element, if it exists.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DBElement
The element from which we try to obtain AnalyticalNodeData.
Remarks
If the input element doesn't have AnalyticalNodeData than it retuns a null reference (Nothing in Visual Basic). The input element should be a ReferencePoint.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |