CanPostCommand Method


Identifies if the given command can be posted, using PostCommand(RevitCommandId).

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool CanPostCommand(
	RevitCommandId commandId
)
Visual Basic
Public Function CanPostCommand ( _
	commandId As RevitCommandId _
) As Boolean
Visual C++
public:
bool CanPostCommand(
	RevitCommandId^ commandId
)

Parameters

commandId
Type: Autodesk.Revit.UIRevitCommandId
The command Id.

Remarks

Only members of Autodesk.Revit.UI.PostableCommand or external commands can be posted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when commandId is a null reference (Nothing in Visual Basic).

See Also