CanPostCommand Method


UIApplication Can Post Command Method

Identifies if the given command can be posted, using PostCommand(RevitCommandId) .

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanPostCommand(
	RevitCommandId commandId
)

Parameters

commandId RevitCommandId
The command Id.

Return Value

Boolean
Exceptions
Exception Condition
ArgumentNullException Thrown when commandId is .
Remarks
Only members of Autodesk.Revit.UI.PostableCommand or external commands can be posted.
See Also