CreateAreaBasedLoadBoundaryLines Method


Creates area based load boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public static IList<CurveElement> CreateAreaBasedLoadBoundaryLines(
	Document document,
	IList<Curve> curves,
	ElementId levelId
)
Visual Basic
Public Shared Function CreateAreaBasedLoadBoundaryLines ( _
	document As Document, _
	curves As IList(Of Curve), _
	levelId As ElementId _
) As IList(Of CurveElement)
Visual C++
public:
static IList<CurveElement^>^ CreateAreaBasedLoadBoundaryLines(
	Document^ document, 
	IList<Curve^>^ curves, 
	ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which to create the area based load boundary lines.
curves
Type: System.Collections.GenericIListCurve
The curves.
levelId
Type: Autodesk.Revit.DBElementId
The id of level.

Return Value

The newly created area based load boundary lines.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException document is not a project document. -or- The input curves contains a null pointer or a curve that is not bounded. -or- The input curves contains at least one curve which is degenerate (its length is too close to zero). -or- The ElementId levelId is not a Level. -or- The input curves contains a curve doesn't lie in the plane of the level.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also