Curve |
Creates area based load boundary lines.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<CurveElement> CreateAreaBasedLoadBoundaryLines(
Document document,
IList<Curve> curves,
ElementId levelId
)
Parameters
- document Document
- The document in which to create the area based load boundary lines.
- curves IList Curve
- The curves.
- levelId ElementId
- The id of level.
Return Value
IList CurveElementThe newly created area based load boundary lines.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The input curves contains a null pointer or a curve that is not bounded. -or- The input curves contains at least one curve which is degenerate (its length is too close to zero). -or- The ElementId levelId is not a Level. -or- The input curves contains a curve doesn't lie in the plane of the level. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |