Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- componentIndex
- Type: SystemInt32
The component index, must be between 0 and ShellComponentCount – 1, inclusive.
Return Value
The component.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Shell component index componentIndex is out of range. |