Triangulated |
Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- componentIndex Int32
- The component index, must be between 0 and ShellComponentCount – 1, inclusive.
Return Value
TriangulatedShellComponentThe component.

Exception | Condition |
---|---|
ArgumentException | Shell component index componentIndex is out of range. |