IsAdaptivePoint Method


Verifies if the Reference Point is an Adaptive Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool IsAdaptivePoint(
	Document doc,
	ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptivePoint ( _
	doc As Document, _
	refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptivePoint(
	Document^ doc, 
	ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The Document
refPointId
Type: Autodesk.Revit.DBElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Point (Placement Point or Shape Handle Point).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also