PostCommand Method


Posts the command to the Revit message queue to be invoked when control returns from the current API context.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void PostCommand(
	RevitCommandId commandId
)
Visual Basic
Public Sub PostCommand ( _
	commandId As RevitCommandId _
)
Visual C++
public:
void PostCommand(
	RevitCommandId^ commandId
)

Parameters

commandId
Type: Autodesk.Revit.UIRevitCommandId
The command Id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when commandId is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionIf the command cannot be posted.
Autodesk.Revit.ExceptionsInvalidOperationException If there is a command already been posted.

See Also