Constructs a NumericRevisionSettings object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- startNumber
- Type: SystemInt32
The start number for the sequence.
- prefix
- Type: SystemString
The prefix string for each revision number in the sequence.
- suffix
- Type: SystemString
The suffix string for each revision number in the sequence.
Remarks
The starting number parameter accepts any non-negative integer, and the prefix and suffix strings are allowed to be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The given value for startNumber is negative. |