NumericRevisionSettings Constructor (Int32, String, String)


Numeric Revision Settings(Int 32, String, String) Constructor

Constructs a NumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public NumericRevisionSettings(
	int startNumber,
	string prefix,
	string suffix
)

Parameters

startNumber Int32
The start number for the sequence.
prefix String
The prefix string for each revision number in the sequence.
suffix String
The suffix string for each revision number in the sequence.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for startNumber is negative.
Remarks
The starting number parameter accepts any non-negative integer, and the prefix and suffix strings are allowed to be empty.
See Also