IsLevelWithinRange Method


Checks whether the given level is between the bottom level and the top level (including the bottom level and the top level) of the area based load boundary line.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public bool IsLevelWithinRange(
	ElementId levelId
)
Visual Basic
Public Function IsLevelWithinRange ( _
	levelId As ElementId _
) As Boolean
Visual C++
public:
bool IsLevelWithinRange(
	ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DBElementId
The id of the Level.

Return Value

True if given level is between the bottom level and the top level, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId levelId is not a Level.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also