GetDatumExtentTypeInView Method


Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public DatumExtentType GetDatumExtentTypeInView(
	DatumEnds datumEnd,
	View view
)
Visual Basic
Public Function GetDatumExtentTypeInView ( _
	datumEnd As DatumEnds, _
	view As View _
) As DatumExtentType
Visual C++
public:
DatumExtentType GetDatumExtentTypeInView(
	DatumEnds datumEnd, 
	View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DBDatumEnds
Specifies one end of the curve representing the datum plane in the view.
view
Type: Autodesk.Revit.DBView
The view in which to evaluate the datum extent settings.

Return Value

The extent type.

Remarks

In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The datum plane cannot be visible in the view.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also